[PATCH] staging: media: atomisp: Fix error path in lm3554_probe()
alex.dewar90 at gmail.com
Thu Sep 3 18:21:30 UTC 2020
> You're right. I wonder if there is really any need for the
> lm3554_gpio_uninit() function at all? It's basically the same as
> lm3554_gpio_init() except for the order of function calls. Probably
> we could just rename lm3554_gpio_init() to something like
> lm3554_gpio_set_default() and use it in both the probe() and remove
I think you probably also don't want to return error values from
lm3554_gpio_uninit() as it is only called on module removal, so it'd
probably make more sense to just print a warning and carry on. I'll do
this as a separate patch and send it to the list, though.
v2 to follow...
> But I don't know the code and can't test it so let's leave that for
> another day.
> We still do need to clean up if atomisp_register_i2c_module() fails
> though, and the timer as well so could you resend a v2?
> dan carpenter
More information about the devel