[PATCH 1/2] MAINTAINERS: Add entry for fieldbus subsystem

Joe Perches joe at perches.com
Thu May 23 21:02:16 UTC 2019


On Thu, 2019-05-23 at 16:23 -0400, Sven Van Asbroeck wrote:
> On Thu, May 23, 2019 at 4:00 PM Joe Perches <joe at perches.com> wrote:
> > trivia: anybuss looks like a misspelling.
> > It might be better as anybus-s.
> This came up as well during the review process. When we insert a separator,
> the include files start looking like anybus-s-controller.h, and the structs
> become like struct anybus_s_ops. It then no longer looks like a misspelling,
> but becomes harder to read?
> 
> An alternative solution is to get rid of the 's' suffix altogether. Anybus-S
> is the only flavour we support right now. Although that may obviously
> change in the future.

anybuss just looked odd to me.

Whatever you choose is up to you and
no doubt you'll choose well.

cheers, Joe




More information about the devel mailing list