[PATCH 1/2] staging: rtl8712: r8712_setdatarate_cmd(): Change

Nishka Dasgupta nishkadg.linux at gmail.com
Mon Jun 10 04:32:27 UTC 2019


On 07/06/19 7:45 PM, Dan Carpenter wrote:
> Probably you sent this patch unintentionally.  The subject doesn't make
> any sort of sense.  :P

So the problem with the subject line is that git send-email and vim (as 
configured on my laptop) tend to line-wrap even the subject line. Since 
I have two patches that do the same thing for different functions, I 
felt I should have the driver and the function name in the subject line 
(to avoid confusion between the patches and to allow for easy searching 
later). But that doesn't leave enough space in the subject line for 
"Change return values/type" or any other descriptive message. What 
should I do?


> On Fri, Jun 07, 2019 at 07:36:57PM +0530, Nishka Dasgupta wrote:
>> Change the return values of function r8712_setdatarate_cmd from _SUCCESS
>> and _FAIL to 0 and -ENOMEM respectively.
>> Change the return type of the function from u8 to int to reflect this.
>> Change the call site of the function to check for 0 instead of _SUCCESS.
>> (Checking that the return value != 0 is not necessary; the return value
>    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>> itself can simply be passed into the conditional.)
>    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^



> This is obvious.  No need to mention it in the commit message.

Okay, I'll amend that.

>> diff --git a/drivers/staging/rtl8712/rtl871x_ioctl_linux.c b/drivers/staging/rtl8712/rtl871x_ioctl_linux.c
>> index b424b8436fcf..761e2ba68a42 100644
>> --- a/drivers/staging/rtl8712/rtl871x_ioctl_linux.c
>> +++ b/drivers/staging/rtl8712/rtl871x_ioctl_linux.c
>> @@ -1367,7 +1367,7 @@ static int r8711_wx_set_rate(struct net_device *dev,
>>   			datarates[i] = 0xff;
>>   		}
>>   	}
>> -	if (r8712_setdatarate_cmd(padapter, datarates) != _SUCCESS)
>> +	if (r8712_setdatarate_cmd(padapter, datarates))
>>   		ret = -ENOMEM;
>>
>>   	return ret;
> 
> 
> It would be better to write this like so:
> 
> 	ret = r8712_setdatarate_cmd(padapter, datarates);
> 	if (ret)
> 		return ret;
> 
> 	return 0;
> 
> Or you could write it like:
> 
> 	return r8712_setdatarate_cmd(padapter, datarates);

Okay, since this is the only point at which a return happens in this 
function, I can do this.

> Which ever one you prefer is fine
Thanking you,
Nishka

> regards,
> dan carpenter
> 



More information about the devel mailing list