[RESEND PATCH v5 00/10] staging: mt7621-gpio: use mediatek as binding instead of custom mtk

Sergio Paracuellos sergio.paracuellos at gmail.com
Sun May 20 13:00:17 UTC 2018


The following series updated mt7621-gpio driver to use 'mediatek'
which is already defined in kernel bindings documentation instead
of add a new custom one 'mtk' for this company. mt7621-gpio device-tree
documentation has been added also to the staging driver directory.

I resent all of them as you said me, Greg.

v5:
 - PATCH 5 ("staging: mt7621-gpio: avoid use of globals and use
   platform_data instead") was still missing folowings to be 
   properly working:
    + The data passed between irq related functions and the ones 
      which have been retrieved were different. Also first data haven't 
      properly set on irq_domain_add_linear call where it was passing 
      NULL instead. Fix those.
 - Join TODO's modifications patches (PATCH 1 and 11) in one which just 
   makes empty the file.

v4:
 - Only PATCH 5 ("staging: mt7621-gpio: avoid use of globals and use
   platform_data instead") has changes:
    + avoid call to gpiochip_add in probe function because function
      devm_gpiochip_add_data is being used instead.
    + Call irq_set_chip_data in mediatek_gpio_gpio_map to make data
      properly passed to interrupts related functions.

v3:
 - Fix condition for check for a valid gpio id in driver probe function
   included in the PATCH 8 ("staging: mt7621-gpio: avoid devm_kzalloc()
   hidden inside declarations and refactor function a bit") of the series.
 - Rest of patches are not modified at all.

v2:
 - Join some patch ("staging: mt7621-gpio: avoid use of globals
   and use platform_data instead") with the needed fixes to make
   it work pointed out by NeilBrown
 - Add gpio interrupts to documentation and device tree in order to
   can try them
 - Other minor code cleanups have been added also.

This changes have been reviewed and tested by NeilBrown but I don't
know if I have to add those information to the patches by myself if
I resend the series or should be added by you Greg when the patches 
are added to the kernel tree.

Hope this helps.

Best regards,
     Sergio Paracuellos


Sergio Paracuellos (10):
  staging: mt7621-gpio: dt-bindings: add documentation for mt7621-gpio
  staging: mt7621-dts: update gpios related entries to use 'mediatek'
  staging: mt7621-gpio: replace 'mtk' to use correct one 'mediatek'
  staging: mt7621-gpio: avoid use of globals and use platform_data
    instead
  staging: mt7621-dts: add interrupt device tree nodes for the gpio
    controller
  staging: mt7621-gpio: dt-bindings: add interrupt nodes to bindings doc
  staging: mt7621-gpio: avoid devm_kzalloc() hidden inside declarations
    and refactor function a bit
  staging: mt7621-gpio: use ternary operator in return in
    mediatek_gpio_get_direction
  staging: mt7621-gpio: use MTK_BANK_WIDTH instead of magic number
  staging: mt7621-gpio: update TODO file

 drivers/staging/mt7621-dts/mt7621.dtsi             |  11 +-
 drivers/staging/mt7621-gpio/TODO                   |   3 -
 drivers/staging/mt7621-gpio/gpio-mt7621.c          | 116 +++++++++++++--------
 .../staging/mt7621-gpio/mediatek,mt7621-gpio.txt   |  58 +++++++++++
 4 files changed, 139 insertions(+), 49 deletions(-)
 create mode 100644 drivers/staging/mt7621-gpio/mediatek,mt7621-gpio.txt

-- 
2.7.4



More information about the devel mailing list