[PATCH 2/8] staging: mt7621-mmc: Remove multiple assignments

Christian Lütke-Stetzkamp christian at lkamp.de
Tue Apr 24 18:01:23 UTC 2018


Fix checkpatch: multiple assignments should be avoided, to improve
readability.
It aslo moves the second assignment out of the if/else block, that is
valid, because drv_mode is of type msdc_mode, an enum with only those
three elements, so one of the if/ else if statements is always
taken. And the second assignment can happen after the conditions.

Signed-off-by: Christian Lütke-Stetzkamp <christian at lkamp.de>
Reviewed-by: NeilBrown <neil at brown.com>
---
 drivers/staging/mt7621-mmc/sd.c | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/mt7621-mmc/sd.c b/drivers/staging/mt7621-mmc/sd.c
index a3e2c9769591..d464e2a321da 100644
--- a/drivers/staging/mt7621-mmc/sd.c
+++ b/drivers/staging/mt7621-mmc/sd.c
@@ -1397,11 +1397,12 @@ static int msdc_do_request(struct mmc_host *mmc, struct mmc_request *mrq)
 
 		/* deside the transfer mode */
 		if (drv_mode[host->id] == MODE_PIO)
-			host->dma_xfer = dma = 0;
+			host->dma_xfer = 0;
 		else if (drv_mode[host->id] == MODE_DMA)
-			host->dma_xfer = dma = 1;
+			host->dma_xfer = 1;
 		else if (drv_mode[host->id] == MODE_SIZE_DEP)
-			host->dma_xfer = dma = ((host->xfer_size >= dma_size[host->id]) ? 1 : 0);
+			host->dma_xfer = ((host->xfer_size >= dma_size[host->id]) ? 1 : 0);
+		dma = host->dma_xfer;
 
 		if (read) {
 			if ((host->timeout_ns != data->timeout_ns) ||
-- 
2.16.1



More information about the devel mailing list