[PATCH 0/3] staging: media: Replace a bit shift.

Chris Moore moore at free.fr
Thu Mar 23 06:46:30 UTC 2017


Hi,

Le 22/03/2017 à 05:26, Arushi Singhal a écrit :
> Replace a bit shift by a use of BIT in media driver.
>
> Arushi Singhal (3):
>    staging: media: Replace a bit shift by a use of BIT.
>    staging: media: davinci_vpfe: Replace a bit shift by a use of BIT.
>    staging: media: omap4iss: Replace a bit shift by a use of BIT.
>
>   .../media/atomisp/pci/atomisp2/atomisp_cmd.c       | 12 +++++-----
>   .../atomisp/pci/atomisp2/atomisp_compat_css20.c    |  6 ++---
>   .../media/atomisp/pci/atomisp2/atomisp_drvfs.c     |  6 ++---
>   .../media/atomisp/pci/atomisp2/atomisp_v4l2.c      | 18 +++++++--------
>   .../media/atomisp/pci/atomisp2/hmm/hmm_bo.c        |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_ipipe.c   |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_ipipeif.c |  2 +-
>   drivers/staging/media/davinci_vpfe/dm365_isif.c    | 26 +++++++++++-----------
>   drivers/staging/media/davinci_vpfe/dm365_resizer.c |  6 ++---
>   drivers/staging/media/omap4iss/iss_csi2.c          |  2 +-
>   drivers/staging/media/omap4iss/iss_ipipe.c         |  2 +-
>   drivers/staging/media/omap4iss/iss_ipipeif.c       |  2 +-
>   drivers/staging/media/omap4iss/iss_resizer.c       |  2 +-
>   13 files changed, 44 insertions(+), 44 deletions(-)
>

Most of these replacements add redundant parentheses around the BIT macro.
IMHO this makes the code less readable.
So I suggest (BIT(c)) -> BIT(c).

Cheers,
Chris



More information about the devel mailing list