[PATCH 00/11] staging: comedi: jr3_pci: more tidy-ups and stuff

Ian Abbott abbotti at mev.co.uk
Wed Mar 8 18:44:22 UTC 2017


Another series of patches for the "jr3_pci" driver.

Patches 01 to 06 reorganize and rename various types, parameters, and
variables to avoid overloading the term "channel" (reserving it to refer
to a Comedi channel), and to simplify the code slightly.

Patch 07 changes some debug logs to reduce clutter.

Patch 08 replaces a run-time check with a compile-time check.

Patch 09 checks the PCI region is large enough for the board model.

Patch 10 changes the initial ranges of a couple of dummy channels per
subdevice to match their final ranges for consistency.

Patch 11 just changes the module description string.

01) staging: comedi: jr3_pci: rename struct jr3_channel to jr3_sensor
02) staging: comedi: jr3_pci: rename channel to sensor
03) staging: comedi: jr3_pci: rename data to sensor
04) staging: comedi: jr3_pci: rename 'channel' to 'block'
05) staging: comedi: jr3_pci: separate out block type
06) staging: comedi: jr3_pci: use struct jr3_block instead of jr3_t
07) staging: comedi: jr3_pci: omit pointless debug info
08) staging: comedi: jr3_pci: check sizes at compile time
09) staging: comedi: jr3_pci: check PCI BAR 0 size
10) staging: comedi: jr3_pci: fix initial range[8] max value
11) staging: comedi: jr3_pci: change module description

 drivers/staging/comedi/drivers/jr3_pci.c | 193 +++++++++++++++----------------
 drivers/staging/comedi/drivers/jr3_pci.h |  18 ++-
 2 files changed, 100 insertions(+), 111 deletions(-)


More information about the devel mailing list