[PATCH 00/19] staging: ks7010: refactor host interface

Tobin C. Harding me at tobin.cc
Wed Apr 26 00:55:05 UTC 2017


This is an attempt to improve the readability of the host interface
code, and ease future development. Refactoring only, no changes to the
functionality of the code.

Patch 01 renames a constant to use adjective instead of noun.

Patch 02 removes redundant code.

Patch 03 removes unused local variable.

Patch 04 moves null check closer to memory allocation.

Patch 05 removes magic numbers.

Patch 06 removes duplicate code.

Patch 07 refactors call to kmalloc(), uses local variable to separate
expression, calculating size of allocation, from call to kmalloc().

Patch 08 adds a helper function to reduce code duplication.

Patch 09 abstracts connection status flag access.

Patch 10 adds enumeration type 'sleep_mode_type' instead of preprocessor defines.

Patch 11 fixes checkpatch warning, multiple new lines.

Patch 12 makes uniform the abbreviation used for 'management' when
naming identifiers.

Patch 13 removes unnecessary void * cast from calls to netdev_priv().

Patch 14 inverts 'if' statement conditional, adding 'continue'
statement to continue loop. Reduces indentation of subsequent code.

Patch 15 cleans up macro definition, removes commented out code and
braces. This macro causes two checkpatch checks to be emitted
(MACRO_ARG_REUSE, MACRO_ARG_PRECEDENCE), please review carefully.

Patch 16 adds enumeration type 'multi_cast_filter_type' instead of preprocessor defines.

Patch 17 fixes/adds enumeration tags.

Patch 18 renames header and source files 'ks_hostif' to 'hostif'.

Patch 19 renames header and source files 'ks7010_sdio' to 'sdio'.

Patch series was created using `git format-patch -M ...`

Series is untested, builds on x86_64 and PowerPC.

Tobin C. Harding (19):
  staging: ks7010: rename constant SLP_SLEEP to SLP_ASLEEP
  staging: ks7010: remove unnecessary address check
  staging: ks7010: remove unused local variable eap_key
  staging: ks7010: move skb null check near allocation
  staging: ks7010: remove magic numbers
  staging: ks7010: remove duplicate code
  staging: ks7010: clean memory allocation
  staging: ks7010: add hostif_generic_request()
  staging: ks7010: abstract connection status
  staging: ks7010: add enum sleep_mode_type
  staging: ks7010: fix checkpatch LINE_SPACING
  staging: ks7010: make abbreviation mgmt uniform
  staging: ks7010: remove cast from netdev_priv()
  staging: ks7010: continue from loop on unmatched mac
  staging: ks7010: clean up macro ps_confirm_wait_inc
  staging: ks7010: add enum multicast_filter_type
  staging: ks7010: fix enumeration tags
  staging: ks7010: rename ks_hostif to hostif
  staging: ks7010: rename ks_hostif to hostif

 drivers/staging/ks7010/Makefile                  |   2 +-
 drivers/staging/ks7010/eap_packet.h              |   2 +
 drivers/staging/ks7010/{ks_hostif.c => hostif.c} | 366 +++++++++------------
 drivers/staging/ks7010/{ks_hostif.h => hostif.h} |  43 +--
 drivers/staging/ks7010/ks_wlan.h                 |   6 +-
 drivers/staging/ks7010/ks_wlan_net.c             | 388 ++++++++++-------------
 drivers/staging/ks7010/{ks7010_sdio.c => sdio.c} |  12 +-
 drivers/staging/ks7010/{ks7010_sdio.h => sdio.h} |   0
 8 files changed, 358 insertions(+), 461 deletions(-)
 rename drivers/staging/ks7010/{ks_hostif.c => hostif.c} (89%)
 rename drivers/staging/ks7010/{ks_hostif.h => hostif.h} (97%)
 rename drivers/staging/ks7010/{ks7010_sdio.c => sdio.c} (99%)
 rename drivers/staging/ks7010/{ks7010_sdio.h => sdio.h} (100%)

-- 
2.7.4



More information about the devel mailing list