[PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

Dexuan Cui decui at microsoft.com
Tue Aug 23 04:42:41 UTC 2016


1. use zero-length array to make the code more readable.
2. remove an unused struct member.
3. small error handling improvement to some error cases.

Dexuan Cui (5):
  PCI: hv: use zero-length message in struct pci_packet
  PCI: hv: use pci_function_description[0] in struct definitions
  PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
  PCI: hv: hv_compose_msi_msg: handle the 'ret' value
  PCI: hv: hv_pci_generic_compl(): handle the error case

 drivers/pci/host/pci-hyperv.c | 56 ++++++++++++++++++++++---------------------
 1 file changed, 29 insertions(+), 27 deletions(-)

-- 
2.7.4



More information about the devel mailing list