Re: 答复: [PATCH] staging: sm750:Fixthe Makefile option error

陈华才 chenhc at lemote.com
Mon Apr 27 02:04:20 UTC 2015


Hi, Sudip and Teddy,

I have found the root cause of Logo problem:
1, enable hw_accel, staging driver cannot show logo.
2, disable hw_accel, staging driver can show logo.
3, both enable/disable hw_accel, my driver (1.0.8) can show logo.
Deep in code: 
In staging driver, drivers/staging/sm750fb/sm750.c, lynxfb_ops_imageblit(), if image->depth != 1, it returns and do nothing. 
In my driver (1.0.8), if image->depth != 1, it fallback to cfb_imageblit().

I will send a patch to fix this.

Huacai
 
------------------ Original ------------------
From:  "Sudip Mukherjee"<sudipm.mukherjee at gmail.com>;
Date:  Fri, Apr 24, 2015 04:25 PM
To:  "陈华才"<chenhc at lemote.com>; 
Cc:  "Teddy Wang 王力强"<teddy.wang at siliconmotion.com>; "Binbin Zhou"<zhoubb at lemote.com>; "Greg Kroah-Hartman"<gregkh at linuxfoundation.org>; "devel"<devel at driverdev.osuosl.org>; "Fuxin Zhang"<zhangfx at lemote.com>; 
Subject:  Re:  答复: [PATCH] staging: sm750:Fixthe Makefile option error

 
On Fri, Apr 24, 2015 at 03:33:58PM +0800, 陈华才 wrote:
> Hi, Sudip,
> 
> Upstream driver still can't show logo, we are debugging.

Hi Huacai,
I checked with the upstream driver only.
I checked with next-20150423 and it showed me the penguin logo on upper
left hand corner of my screen when CONFIG_FB_SM750=y.
only extra thing was that your patch of the Makefile was applied.
maybe you can consider gifting me one your notepads so that I can
also see the problem :)

regards
sudip

>


More information about the devel mailing list