[PATCH 2/3] staging: dgap: adds missing iounmap for re_map_port in dgap_release_remap()

DaeSeok Youn daeseok.youn at gmail.com
Thu Sep 25 00:21:50 UTC 2014


Hi,

2014-09-24 18:42 GMT+09:00 Dan Carpenter <dan.carpenter at oracle.com>:
> On Wed, Sep 24, 2014 at 12:36:48PM +0300, Dan Carpenter wrote:
>> On Tue, Sep 23, 2014 at 09:22:08AM +0900, Daeseok Youn wrote:
>> > Signed-off-by: Daeseok Youn <daeseok.youn at gmail.com>
>> > ---
>> >  drivers/staging/dgap/dgap.c |    1 +
>> >  1 files changed, 1 insertions(+), 0 deletions(-)
>> >
>> > diff --git a/drivers/staging/dgap/dgap.c b/drivers/staging/dgap/dgap.c
>> > index 779d144..637ea8a 100644
>> > --- a/drivers/staging/dgap/dgap.c
>> > +++ b/drivers/staging/dgap/dgap.c
>> > @@ -1026,6 +1026,7 @@ static void dgap_release_remap(struct board_t *brd)
>> >     release_mem_region(brd->membase, 0x200000);
>> >     release_mem_region(brd->membase + PCI_IO_OFFSET, 0x200000);
>> >     iounmap(brd->re_map_membase);
>> > +   iounmap(brd->re_map_port);
>>
>>
>> I don't think it matters, but at least aesthetically it would be better
>> to unmap first and then release the regions.  (You can do this in a
>> different patch).
Ok. I will make another patch as your comment.
>>
>
> Also dgap_do_remap() unwinds in the wrong order and is sucky.  It should
> use gotos.
>
> Also the name dgap_do_remap() isn't great.  Remap is a verb not a noun
> so the "_do" isn't needed.  Just dgap_remap() and dgap_release_remap()
> could be changed to dgap_unmap().
OK. rename those functions.

Thanks.

regards,
Daeseok Youn.
>
> regards,
> dan carpenter
>


More information about the devel mailing list