[PATCH RESEND 2/2] staging: binder: Code simplification

Greg KH gregkh at linuxfoundation.org
Thu Apr 17 03:16:14 UTC 2014


On Tue, Apr 15, 2014 at 12:03:06PM +0200, Mathieu Maret wrote:
> Remove duplicate code
> 
> Signed-off-by: Mathieu Maret <mathieu.maret at gmail.com>
> ---
>  drivers/staging/android/binder.c | 7 ++-----
>  1 file changed, 2 insertions(+), 5 deletions(-)
> 
> diff --git a/drivers/staging/android/binder.c b/drivers/staging/android/binder.c
> index 3dca577..c29c3c7 100644
> --- a/drivers/staging/android/binder.c
> +++ b/drivers/staging/android/binder.c
> @@ -2686,11 +2686,8 @@ static long binder_ioctl(struct file *filp, unsigned int cmd, unsigned long arg)
>  	case BINDER_VERSION:{
>  		struct binder_version __user *ver = ubuf;
>  
> -		if (size != sizeof(struct binder_version)) {
> -			ret = -EINVAL;
> -			goto err;
> -		}
> -		if (put_user(BINDER_CURRENT_PROTOCOL_VERSION,
> +		if (size != sizeof(struct binder_version) ||
> +		    put_user(BINDER_CURRENT_PROTOCOL_VERSION,
>  			     &ver->protocol_version)) {
>  			ret = -EINVAL;
>  			goto err;

I agree with Dan, the original code was easier to read.

thanks,

greg k-h


More information about the devel mailing list