[PATCH 18/18] staging: comedi: ii_pci20kc: remove comment about 2.4 kernels

Ian Abbott abbotti at mev.co.uk
Thu Apr 11 10:01:31 UTC 2013


On 2013-04-10 19:32, H Hartley Sweeten wrote:
> This comment about using ioremap() for 2.4 kernels is not necessary.
>
> Signed-off-by: H Hartley Sweeten <hsweeten at visionengravers.com>
> Cc: Ian Abbott <abbotti at mev.co.uk>
> Cc: Greg Kroah-Hartman <gregkh at linuxfoundation.org>
> ---
>   drivers/staging/comedi/drivers/ii_pci20kc.c | 3 ---
>   1 file changed, 3 deletions(-)
>
> diff --git a/drivers/staging/comedi/drivers/ii_pci20kc.c b/drivers/staging/comedi/drivers/ii_pci20kc.c
> index 03719f2..ee7537d 100644
> --- a/drivers/staging/comedi/drivers/ii_pci20kc.c
> +++ b/drivers/staging/comedi/drivers/ii_pci20kc.c
> @@ -77,9 +77,6 @@ options for PCI-20341M:
>   	     3  200
>   */
>
> -/* XXX needs to use ioremap() for compatibility with 2.4 kernels.  Should also
> - * check_mem_region() etc. - fmhess */
> -
>   #include "../comedidev.h"
>
>   #define PCI20000_ID			0x1d
>

This is a pretty stupid and broken driver anyway.  We should probably 
get rid of it as there's no way it could actually function in its 
current state.

-- 
-=( Ian Abbott @ MEV Ltd.    E-mail: <abbotti at mev.co.uk>        )=-
-=( Tel: +44 (0)161 477 1898   FAX: +44 (0)161 718 3587         )=-



More information about the devel mailing list