[PATCH 52/79] staging: comedi: ni_atmio16d: cleanup dev->board_name usage

H Hartley Sweeten hsweeten at visionengravers.com
Tue Apr 9 23:25:25 UTC 2013


This legacy driver does no additional probing so the dev->board_name
will already be properly initialized by the comedi core before calling
the (*attach) function.

Remove the unnecessary initialization of dev->board_name and use it
when requesting the resources instead of the open-coded strings.

Signed-off-by: H Hartley Sweeten <hsweeten at visionengravers.com>
Cc: Ian Abbott <abbotti at mev.co.uk>
Cc: Greg Kroah-Hartman <gregkh at linuxfoundation.org>
---
 drivers/staging/comedi/drivers/ni_atmio16d.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/staging/comedi/drivers/ni_atmio16d.c b/drivers/staging/comedi/drivers/ni_atmio16d.c
index 4a17494..faf3c37 100644
--- a/drivers/staging/comedi/drivers/ni_atmio16d.c
+++ b/drivers/staging/comedi/drivers/ni_atmio16d.c
@@ -647,14 +647,12 @@ static int atmio16d_attach(struct comedi_device *dev,
 	/* make sure the address range is free and allocate it */
 	iobase = it->options[0];
 	printk(KERN_INFO "comedi%d: atmio16d: 0x%04lx ", dev->minor, iobase);
-	if (!request_region(iobase, ATMIO16D_SIZE, "ni_atmio16d")) {
+	if (!request_region(iobase, ATMIO16D_SIZE, dev->board_name)) {
 		printk("I/O port conflict\n");
 		return -EIO;
 	}
 	dev->iobase = iobase;
 
-	dev->board_name = board->name;
-
 	ret = comedi_alloc_subdevices(dev, 4);
 	if (ret)
 		return ret;
-- 
1.8.1.4




More information about the devel mailing list