[PATCH 01/21] Staging: bcm: Remove typedef from "eInterface_setting" in Adapter.h
dan.carpenter at oracle.com
Mon May 21 12:54:05 UTC 2012
On Mon, May 21, 2012 at 08:36:38AM -0400, Kevin McKinney wrote:
> On Mon, May 21, 2012 at 3:15 AM, Dan Carpenter <dan.carpenter at oracle.com> wrote:
> > On Sun, May 20, 2012 at 04:09:51PM -0400, Kevin McKinney wrote:
> >> This patch removes the typedef from
> >> eInterface_setting, remames the enum
> >> to INTERFACE_SETTING.
> > On these ones I would have prefered if we could have gone straight
> > to kernel style naming like "enum interface_setting". We don't like
> > ALL_CAPS struct names and we don't like CamelCase names.
> > How much work is it to redo these?
> Dan, it is not much work to redo these. I will change the names to our
> kernel style naming convention.
That would be so great. Some of them might be sort of very
commonish type names so if you want to put a bcm_ infront like
enum bcm_interface_setting that would be ok.
Use your own judgement on that.
More information about the devel