[PATCH] Staging: android: alarm: fixed quoted string split across lines

Joe Perches joe at perches.com
Sun May 20 20:38:04 UTC 2012


On Sun, 2012-05-20 at 13:28 -0700, David Rientjes wrote:
> On Sun, 20 May 2012, Nasir Abed wrote:
> 
> > diff --git a/drivers/staging/android/alarm.c b/drivers/staging/android/alarm.c
> > index c68950b..4ea07bb 100644
> > --- a/drivers/staging/android/alarm.c
> > +++ b/drivers/staging/android/alarm.c
> > @@ -302,8 +302,8 @@ int android_alarm_set_rtc(struct timespec new_time)
> >  	}
> >  	ret = rtc_set_time(alarm_rtc_dev, &rtc_new_rtc_time);
> >  	if (ret < 0)
> > -		pr_alarm(ERROR, "alarm_set_rtc: "
> > -			"Failed to set RTC, time will be lost on reboot\n");
> > +		pr_alarm(ERROR,
> > +			 "alarm_set_rtc: Failed to set RTC, time will be lost on reboot\n");
> >  err:
> >  	wake_unlock(&alarm_rtc_wake_lock);
> >  	mutex_unlock(&alarm_setrtc_mutex);
> 
> Looks like this would benefit from using __func__ since it already doesn't 
> represent the correct function name.

true.

Somewhat related, pr_alarm is a poor name choice.
It should probably called alarm_dbg.

o it's a duplicated #define
  it should be in some common #include
o it's a debug test that emits at KERN_INFO





More information about the devel mailing list