[PATCH 3/3] Staging: hv: mousevsc: Use the KBUILD_MODNAME macro

H Hartley Sweeten hartleys at visionengravers.com
Fri Oct 28 23:02:22 UTC 2011


On Friday, October 28, 2011 3:11 PM, K. Y. Srinivasan wrote:
> 
> Use the KBUILD_MODNAME macro.
> 
> Signed-off-by: K. Y. Srinivasan <kys at microsoft.com>
> ---
>  drivers/staging/hv/hv_mouse.c |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/drivers/staging/hv/hv_mouse.c b/drivers/staging/hv/hv_mouse.c
> index c22f729..2c2e1b4 100644
> --- a/drivers/staging/hv/hv_mouse.c
> +++ b/drivers/staging/hv/hv_mouse.c
> @@ -578,7 +578,7 @@ static const struct hv_vmbus_device_id id_table[] = {
>  MODULE_DEVICE_TABLE(vmbus, id_table);
>  
>  static struct  hv_driver mousevsc_drv = {
> -	.name = "mousevsc",
> +	.name = KBUILD_MODNAME,
>  	.id_table = id_table,
>  	.probe = mousevsc_probe,
>  	.remove = mousevsc_remove,

It's just my opinion, but I'm not sure this is better.

By changing the name to KBUILD_MODNAME you can no longer grep the source to
find the driver based on it's name:

$ grep -r name * | grep mousevsc
drivers/staging/hv/hv_mouse.c:  .name = "mousevsc",

Also, doesn't this change the name of the driver from "mousevsc" to "hv_mouse"?
Does anything else need modified to handle the name change or is the matching
handled strictly by the id_table?

Regards,
Hartley




More information about the devel mailing list