[PATCH] staging/xgifb: Convert pci_table entries to PCI_DEVICE (if PCI_ANY_ID is used)

Aaro Koskinen aaro.koskinen at iki.fi
Sun Nov 6 21:37:53 UTC 2011


Hi,

On 6.11.2011, at 23.05, Peter Huewe wrote:
> This patch converts pci_table entries to use the PCI_DEVICE macro,
> if .subvendor and .subdevice are set to PCI_ANY_ID,
> and thus improves readability.
>
> KernelVersion: Staging-20111106
> ---
>  drivers/staging/xgifb/XGI_main.h |   12 ++++--------
>  1 files changed, 4 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/staging/xgifb/XGI_main.h b/drivers/staging/ 
> xgifb/XGI_main.h
> index 71aebe3..0c3f421 100644
> --- a/drivers/staging/xgifb/XGI_main.h
> +++ b/drivers/staging/xgifb/XGI_main.h
> @@ -32,14 +32,10 @@
>  #endif
>
>  static DEFINE_PCI_DEVICE_TABLE(xgifb_pci_table) = {
> -	{PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20, PCI_ANY_ID, PCI_ANY_ID,
> -	 0, 0, 0},
> -	{PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_27, PCI_ANY_ID, PCI_ANY_ID,
> -	 0, 0, 1},
> -	{PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_40, PCI_ANY_ID, PCI_ANY_ID,
> -	 0, 0, 2},
> -	{PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_42, PCI_ANY_ID, PCI_ANY_ID,
> -	 0, 0, 3},
> +	{PCI_DEVICE(PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20), 0, 0, 0},

I think the correct way would be

	{PCI_DEVICE(PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20), .driver_data = 0},

or

	{PCI_VDEVICE(PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20), 0},

But I don't see the driver_data even being used anywhere, so then you  
could
just simply say:

	{PCI_DEVICE(PCI_VENDOR_ID_XG, PCI_DEVICE_ID_XG_20)},

A.




More information about the devel mailing list