[PATCH] staging: brcm80211: brcmfmac: Add and use dhd_dbg
henryp at broadcom.com
Thu May 19 00:46:29 UTC 2011
On 05/18/2011 05:32 PM, Joe Perches wrote:
> On Wed, 2011-05-18 at 15:45 -0700, Henry Ptasinski wrote:
>> On 05/18/2011 11:23 AM, Joe Perches wrote:
>>> All uses of DHD_<TYPE> macros are for debugging only.
>>> Change the multiple uses of DHD_<TYPE>((...)) to dhd_dbg(TYPE, ...)
>>> for a more consistent style.
>> I generally like this approach, but in brcmsmac we've been switching to
>> wiphy_err() and related instead. Any strong argument for one over the
> These aren't described as errors but are debugging messages.
Yes, so wiphy_debug(), wiphy_info(), wiphy_notice(), etc could be used.
It's not as fine grained as the current logging mechanism, so that
would be one argument against using wiphy_*. I don't have a strong
opinion either way, just looking to see which is the generally preferred
approach in the kernel (if there is any preference).
>>> - DHD_TRACE(("%s: Enter\n", __func__));
>>> + dhd_dbg(TRACE, "%s: Enter\n", __func__);
>> I'd propose moving __func__ into the macro definition itself, which
>> would help ensure consistency (and shorten all the debug lines a bit).
> I think TRACE is unnecessary and can be eliminated
> and replaced by the function tracer.
> Not all uses use __func__.
That's just sloppiness on our part. They should all be consistent.
> I think __func__ unnecessary and it should be avoided.
If it's moved into the macro, then there's only one place to change if
you want to delete "__func__"/add it back/include it conditionally.
> Other than that, I've no objections.
>> Also, perhaps rename to "brcm_dbg()", "bcm_dbg()" or something like that
>> and move it into include/bcmutils.h, so brcmsmac can use it as well.
> Your choice.
"brcm_dbg()" seems fine to me.
More information about the devel