audio utility could not detect hdmi device but codec device

Alex Deucher alexdeucher at gmail.com
Mon Feb 28 06:30:11 UTC 2011


On Sun, Feb 27, 2011 at 10:57 PM, hong zhang <henryzhang62 at yahoo.com> wrote:
> Alex,
>
> Thanks for good information. It sounds for transmit side. How about receive side?

Assuming you are sending the appropriate packets, the receiver
(monitor, amplifier, etc.) should just work.  Note that I've only
worked on the transmit side, so I'm not that familiar with the
receiver side.

Alex

>
> ---henry
>
> --- On Sun, 2/27/11, Alex Deucher <alexdeucher at gmail.com> wrote:
>
>> From: Alex Deucher <alexdeucher at gmail.com>
>> Subject: Re: audio utility could not detect hdmi device but codec device
>> To: "hong zhang" <henryzhang62 at yahoo.com>
>> Cc: devel at linuxdriverproject.org
>> Date: Sunday, February 27, 2011, 4:29 PM
>> On Sun, Feb 27, 2011 at 4:17 PM, hong
>> zhang <henryzhang62 at yahoo.com>
>> wrote:
>> > List,
>> >
>> > My TI SoC reference board lacks functionality of audio
>> over HDMI but does have video over HDMI.
>> >
>> > ALSA utility "aplay -l" does not display HDMI but does
>> display codec device.
>> >
>> > I am wondering if hdmi audio is not registered. If
>> yes, how to register it to make hdmi audio device displayed
>> by "aplay -l"
>> >
>> > Any help will be appreciated!
>> >
>>
>> To support audio over hdmi, you need to read back the hdmi
>> edid
>> extensions from the monitor to determine what it's audio
>> capabilities
>> are and then you need to generate the hdmi infoframe
>> packets and mix
>> the sound data into the hdmi data stream.  You need
>> hdmi hardware that
>> is capable of generating the packets and mixing the audio
>> stream.
>>
>> Alex
>>
>> > --henry
>> >
>> >
>> >
>> > _______________________________________________
>> > devel mailing list
>> > devel at linuxdriverproject.org
>> > http://driverdev.linuxdriverproject.org/mailman/listinfo/devel
>> >
>>
>
>
>
>



More information about the devel mailing list