[PATCH 1/1] Rename camel case variables in channel.c

Haiyang Zhang haiyangz at microsoft.com
Thu Sep 23 21:04:02 UTC 2010


> From: Joe Perches [mailto:joe at perches.com]
> Sent: Thursday, September 23, 2010 4:41 PM
> > -	struct hv_monitor_page *monitorPage;
> > +	struct hv_monitor_page *monitorpage;
> 
> Some of these renames would be better with a "_" for
> the CamelCase conversions (ie: CamelCase -> camel_case).

Yes, for longer names I usually insert underscore. For example, 
I changed packetLenAligned to packetlen_aligned.

> > +	struct hv_monitor_page *monitorpage;
> > +	u8 monitorGroup = (u8)channel->OfferMsg.MonitorId / 32;
> > +	u8 monitorOffset = (u8)channel->OfferMsg.MonitorId % 32;
> 
> Why not convert these to monitor_(group|offset)?

That's a good catch. I will update it.

Thanks,

- Haiyang


More information about the devel mailing list