usbip: sometimes stalls at kernel_recvmsg()

Németh Márton nm127 at
Fri Dec 17 05:45:52 UTC 2010

Hello Max,

Max Vozeler wrote:
> Hi Németh,
> On 16.12.2010 08:31, Németh Márton wrote:
>> Németh Márton wrote:
>>> I'm working with usbip and I sometimes see a stall when I run
>>> the "lsusb" command from the userspace. 
> Does it eventually recover?

No, it doesn't. After 120 seconds messages are printed in dmesg
that the "lsusb" process is blocked more than 120 seconds.

>>> I added some debug messages
>>> and it seems that the kernel_recvmsg() in
>>> This is the only place I could find where the TCP messages are arriving in
>>> the usbip code.
>>> What happens if a message does not arrive? Does it stall forever? 
> Yes, it will block until detached or until a TCP
> timeout or error closes the connection.
> The TCP timeout can take several minutes.

What I don't really understand is that how is it possible that
a packet from TCP communication is lost? TCP resends the lost
packets automatically. In my case I run both the usbip server
and client on the same machine using the host name "localhost".
So I assume that there might be a protocol handshake problem

There are, however cases when the timeout is needed, e.g. when
the usbip server and client are physically disconnected so the
TCP packet resend is no more possible.

	Márton Németh

More information about the devel mailing list