[PATCH 2/3]: An implementation of HyperV KVP functionality

Greg KH gregkh at suse.de
Tue Dec 7 23:12:54 UTC 2010


On Tue, Dec 07, 2010 at 03:25:56PM -0700, Ky Srinivasan wrote:
> This patch is re-based on the latest linux-next tree.
> 
> From: K. Y. Srinivasan <ksrinivasan at novell.com>
> 
> Subject: The hv_utils module will be composed of more than one file;
> rename hv_utils.c to accommodate this without changing the module name.
> 
> Signed-off-by: K. Y. Srinivasan <ksrinivasan at novell.com>
> 


Please put the diffstat of the patch in below the signed-off-by: and
after a --- line.


> Index: linux.trees.git/drivers/staging/hv/Makefile
> ===================================================================
> --- linux.trees.git.orig/drivers/staging/hv/Makefile	2010-12-07 07:04:41.000000000 -0500
> +++ linux.trees.git/drivers/staging/hv/Makefile	2010-12-07 08:00:10.000000000 -0500
> @@ -10,3 +10,4 @@ hv_vmbus-y := vmbus_drv.o osd.o \
>  hv_storvsc-y := storvsc_drv.o storvsc.o
>  hv_blkvsc-y := blkvsc_drv.o blkvsc.o
>  hv_netvsc-y := netvsc_drv.o netvsc.o rndis_filter.o
> +hv_utils-y := hv_util.o
> Index: linux.trees.git/drivers/staging/hv/hv_util.c
> ===================================================================
> --- /dev/null	1970-01-01 00:00:00.000000000 +0000
> +++ linux.trees.git/drivers/staging/hv/hv_util.c	2010-12-07 08:00:10.000000000 -0500

Are you renaming the file here?  Are you using git?  If so, it should
produce a patch that shows the rename happened, not this big 'remove it
all and then add it back' type thing.

thanks,

greg k-h



More information about the devel mailing list