dl2k does not work

Purushotham Nayak nayak_purushotham at yahoo.com
Sat Jun 20 14:38:27 UTC 2009

Yes, I want to work on this. I also got the specs from one of the FreeBSD 
sites. I need this device though. I also need another fiber NIC to work with 
it. I'm trying to see if I can get something at work. But if anyone has it, it
would make it easy.

Also, if I contact dlink are they likely to give us a device for working 
on this?

- Purush

----- Original Message ----
From: Greg KH <greg at kroah.com>
To: Florian Weimer <fweimer at bfk.de>
Cc: devel at linuxdriverproject.org
Sent: Friday, June 19, 2009 7:12:23 PM
Subject: Re: dl2k does not work

On Mon, Jun 08, 2009 at 02:04:49PM +0200, Florian Weimer wrote:
> The dl2k driver is not maintained anymore (I've tried to contact the
> Edward Peng, but have never heard back anything).  At least with the
> DGE-550SX card, it doesn't work with modern hardware because under
> load, the card seems to see different queue contents than the host.
> It worked fine in older hosts (but we only stressed receive back than,
> not transmit).  We also went back way early in the 2.6 series to get
> matching kernel versions, and the driver still did not work in the new
> box, so it's not just bitrot ("new" is relative, our debugging
> attempts happened in 2006).
> I guess the lack of synchronization in the code might explain this,
> but I don't know how to fix it.  Perhaps someone more knowledgeable
> could have a look at the driver?
> The FreeBSD folks have specs for the underlying chip (a Tamarack
> TC9021), I believe.

Are they published anywhere?

If so, then it's probably possible to get this working, anyone want to
help out?


greg k-h
devel mailing list
devel at linuxdriverproject.org


More information about the devel mailing list