[PATCH 2/2] rt{2860,2870,3070}sta: Use request_firmware() to load firmware

Greg KH greg at kroah.com
Thu Aug 27 21:23:32 UTC 2009


On Wed, Aug 26, 2009 at 11:34:30PM +0100, Ben Hutchings wrote:
> When originally introduced into staging, these drivers had custom
> firmware-loading code which checked a version number and CRC at the
> end of each blob.  This reintroduces those checks, using crc-ccitt
> instead of custom code.
> 
> rt2870sta and rt3070sta each contain firmware both for RT2870/RT3070
> (first half) and RT3071/RT3072 (second half).  rt3070sta has later
> versions of each.  Given that the version check is >= not ==, this
> code does not distinguish between the different versions by filename.
> 
> The removed firmware will be added to the linux-firmware.git
> repository.

This patch still does not apply, you are patching files that are no
longer in the linux-next tree :(

thanks,

greg k-h



More information about the devel mailing list