LDP and comedi

Frank Mori Hess fmhess at speakeasy.net
Sun Oct 28 18:02:12 UTC 2007


On Sunday 28 October 2007 12:55, Greg KH wrote:
> On Sun, Oct 28, 2007 at 12:19:31PM -0400, Frank Mori Hess wrote:
> > On Friday 26 October 2007 00:38, Greg KH wrote:
> > > Some of the things you might not want in the cvs tree (#ifdef
> > > removals for old kernel versions), but the majority should not be an
> > > issue (typedef removals, whitespace, proper driver core integration,
> > > etc.)
>
> What about these issues?  Will you take patches to remove the backward
> compatibility portions of comedi?

Yes.  Although, most of the remaining compatibility code has always been 
kept in separate header files that are transparently included before the 
kernel's real headers.  So there should be no need to remove it.

> How about driver core intergration?  By its very nature that will not
> work with older (2.4 and most early 2.6) kernel versions.
>
> Is older-kernel support something that you feel is necessary to support
> for a while?

No, the latest release already doesn't support 2.4 kernels.

-- 
Frank

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://driverdev.linuxdriverproject.org/pipermail/driverdev-devel/attachments/20071028/ac2360c1/attachment.asc>


More information about the devel mailing list